Install

Requirements

XPSPL requires >= PHP 5.4.

Composer

XPSPL is installed using (composer).

require: "prggmr/xpspl": "v5.0.0"

Once installed XPSPL’s API will be available after including composer’s vender/autoload.php.

Manual

Warning

This is the legacy installation method.

Only install XPSPL using this if you are using XPSPL < v5.0.0

The manual installation is over the network with a CLI. (link)

The installation requires the CURL and ZIP libraries to be installed on the system and is the legacy installation.

curl -s https://raw.github.com/prggmr/xpspl/master/install | sudo sh

Optional

FTP Module

PHP FTP extension for XPSPL FTP module support.

Networking

PHP Sockets extension for XPSPL Networking module support.

Judy

C Judy 1.0.4 PECL Judy 0.1.4

The Judy library demonstrates improving the database by giving sptorage a linear average performance of 39us per write to a tested 262144.

For installation of Judy C see the README.

For installation of Judy PECL visit here.

Read the Docs v: v5.0.1
Versions
latest
v5.0.1
v5.0.0
v4.0.1
v4.0.0
v3.1.1
v3.1.0
v3.0.0
Downloads
On Read the Docs
Project Home
Builds

Free document hosting provided by Read the Docs.